Brock's Performance

Search Results
You searched for "TRE"

84 FAQs Found
Page 1 of 9
Does Brock's recommend the use of K&N or BMC aftermarket street or race air filters?
 
How do I interpret the map names/abbreviations?
 
How do I register my Brock's Performance Exhaust System, receive Map Support and gain access to the StreetSmart Owners Section (Private) - all in one step?
 
What is the benefit of running a non o-ring chain on the track, and why can't you do any riding on the street with it.
 
I have a street megaphone on a Hayabusa with small box mod, stock filter, PC3USB, 87 pump gas? I have a flat spot with hesitation from 2500 to about 3300. Which map do you recommend for it? Don't want it to run too lean.
 
I originally thought when I installed the TRE, on my Suzuki Hayabusa, the mapping was changing when you shift through the gears but I believe the mapping isn't changing, it's just shutting down the fuel pump in 6th gear. Is my theory correct?
 
I have a '07 ZX14 and I'm considering your Street Meg pipe but have a few questions. 1)I already have a PC3 Power Commander and the secondary throttle plates out(map 011),what horsepower and torque gain can I expect after remapping with your pipe? 2)What is the cost including shipping to Edmonton,Ab.Canada including all fees? 3)Does a full system have an advantage over slip-ons other than weight saving?
 
Do I need to remove the flies on my 2008-09 ZX-14 for maximum performance? I read on the Internet that the flies are opened at the same rate as adding a TRE 008 to the earlier model ZX 14's, so there is no reason to bother removing the flies?
 
The Speedo Healer for my 2008 Hayabusa didn’t work around the stock speed limiter. The product is installed and working properly as far as I can tell. I can program in different % offsets and the speedo reacts like it should, but the bike ran 180MPH in 6th gear on the dyno and signed off.
 
I had a shop install a Streetmeg on my 2008 ZX14 and it started to leak lots of motor oil from the top of engine. What do you think went wrong with the install? Is it coming from the air box or valve cover gasket? Did they plug up the wrong port or hole.?
 
Go to Page :

Can't Find an Answer?
If you cannot find an answer to your question, you can submit it to us and receive an answer by e-mail.

Back to Top